Поиск 0
8 499 455-06-82
с 9:00 до 18:00 по будням
info@digitalangel.ru
Draytek

Обновление VigorACS 2 на Linux

Этот документ демонстрирует, как обновить VigorACS 2 на платформе Linux. ACS 2 совместим со всеми дистрибутивами Linux, включая Ubuntu, OpenSUSE, CentOS, Debian и RedHat. Например, здесь мы будем использовать CentOS 7.

Перед обновлением СКУД обратите внимание на следующий пункт:

Свяжитесь с вашим местным дистрибьютором, чтобы получить установочный файл последней версии VigorACS 2.
Эта статья предназначена для обновления версии VigorACS 2 на платформе Linux.

Обновление VigorACS 2 в Linux
1.Перед обновлением ACS 2 убедитесь, что вы используете права root, также есть некоторые необходимые зависимости для VigorACS 2.

-разархивировать (необходимо перед запуском установочного скрипта)
-bzip2 (необходимо перед запуском скрипта установки)
-net-tools (входит в установочный скрипт)
-vim (включен в сценарий установки)
-libaio1 / libaio-devel (зависимости MariaDB 10, он включен в скрипт установки)
-epel-release / cabextract / xorg-x11-font-utils / fontconfig (пакет шрифтов необходим, если у вас -установлена минимальная версия дистрибутива Linux. Он включен в сценарий установки)
-libcap (libcap требуется для функции захвата пакетов, начиная с ACS 2.4.0. Он включен в сценарий установки)
ПРИМЕЧАНИЕ. Сценарий установки для стандартных дистрибутивов Linux должен включать большинство необходимых зависимостей, но если вы используете не очень распространенный дистрибутив, вам может потребоваться установить зависимости вручную.

a screenshot of Linux

2. Загрузите установленный пакет VigorACS 2 и распакуйте его с помощью команды: # bzip2 -cd VigorACS_Unix_Like_xxxxxx_xxxxx.tar.bz2 | tar xvf -
или #tar -jxvf VigorACS_Unix_Like_xxxxxx_xxxxx.tar.bz2

a screenshot of Linux

3. Перейдите по пути / usr / local / vigoracs / VigorACS / bin и выполните сценарий vigoracs.sh. Сначала введите индекс для остановки службы VigorACS2.

4. Измените привилегии скриптов install.sh и uninstall.sh с помощью команды:
#chmod 755 install.sh uninstall.sh

a screenshot of Linux

5. Запустите установочный файл ./install.sh. Программа установки может попросить вас сначала установить некоторые зависимости. Если вы уже устанавливали его раньше, введите n, чтобы игнорировать этот процесс.

a screenshot of Linux

6. Установите InfluxDB: Если вы обновляете ACS с версии до 2.4.0, введите «3», чтобы установить InfluxDB для записи статистических данных ACS. Если вы уже установили InfluxDB, вы можете пропустить этот шаг.

a screenshot of Linux

7. Обновите OpenJDK: если ваш OpenJDK обновлен до последней версии, вы можете пропустить этот шаг. Введите «4», чтобы обновить Java (OpenJDK). ACS 2.4.0 совместим с OpenJDK 1.8.0_181, обновите OpenJDK, если вы используете старую версию.

a screenshot of Linux

8. Обновите VigorACS 2: введите «6», чтобы обновить VigorACS. Когда вас попросят ввести пароль MySQL, нажмите «Enter» , если вы все еще используете пароль по умолчанию, и убедитесь, что вы можете получить доступ к базе данных успешно. Наконец, подтвердите, что база данных TR-069 была успешно создана, и нажмите опцию 8, чтобы выйти из скрипта.
ПРИМЕЧАНИЕ: Если вы забыли пароль, вы можете обратиться к статье здесь, чтобы сбросить пароль MySQL.

a screenshot of Linux CLI

9. После того, как мы завершили все установленные шаги, перейдите в папку VigorACS / usr / local / vigoracs / VigorACS / bin / и выполните ./vigoracs.sh, введите номер индекса для запуска службы VigorACS.

a screenshot of linux CLI

10. Войдите в ACS и проверьте, обновился ли сервер до новой версии.

a screenshot of ACS 2

Как проверить, успешно ли запустились службы VigorACS 2?
Если VigorACS 2 не может нормально работать, проверьте, есть ли в журнале сервера начальное сообщение, которое можно найти по пути:
tail -f /usr/local/vigoracs/VigorACS/standalone/log/server.log


Сравнение товаров {{compareItems.length}}

Например termit irz модем rl21 atm21 антенна 906 sma 45791
Например termit irz модем rl21 atm21 антенна 906 sma 45791
Мы используем cookie-файлы