0
Каталог товаров
Поиск по каталогу Поиск
Teltonika

Настройка SSTP-туннеля между Teltonika RUTX и устройством Mikrotik

Протокол защищенного туннелирования сокетов (SSTP) - это протокол VPN, предназначенный для передачи трафика PPP через защищенный канал SSL / TLS.

Эта статья содержит руководство по настройке туннеля SSTP между маршрутизаторами RUTXxx (клиент) и Mikrotik (сервер).

Требования:
- Один маршрутизатор RUTXxx любого типа
- Один маршрутизатор Mikrotik (этот пример конфигурации был создан с использованием Mikrotik rb750gr3)
- Сервер должен иметь публичный статический или публичный динамический IP-адрес
- Как минимум одно конечное устройство (ПК, ноутбук) для настройки маршрутизаторов
- Приложение WinBox


Схема конфигурации


 

MikroTik(серверная) конфигурация

Подключитесь к MikroTik с помощью приложения WinBox и нажмите Новый терминал.


Обязательным условием для любого VPN-сервера является получение отсортированных сертификатов. Процедура точно такая же, как и для установки сервера OpenVPN, с небольшим отличием в том, что общее имя действительно имеет значение. Он должен соответствовать либо внешнему IP-адресу, либо внешнему имени хоста - без исключений. Используйте эти команды для создания сертификатов:

/certificate
add name=ca-template common-name=example.com  days-valid=3650 key-size=2048 key-usage=crl-sign,key-cert-sign
add name=server-template common-name=example.com  days-valid=3650 key-size=2048 key-usage=digital-signature,key-encipherment,tls-server
add name=client-template common-name=client.example.com  days-valid=3650 key-size=2048 key-usage=tls-client
sign ca-template name=ca-certificate
sign server-template name=server-certificate ca=ca-certificate
sign client-template name=client-certificate ca=ca-certificate

Вам нужно будет экспортировать корневой сертификат, для этого используйте следующие команды:

/certificate
export-certificate ca-certificate export-passphrase=""

Вместо того, чтобы редактировать зашифрованный профиль по умолчанию, мы можем создать новый. Предполагается, что ваш MikroTik также будет DNS-сервером. И в то время как в этом, создайте безопасный пользователь / пароль:

/ppp
profile add name="vpn-profile" use-encryption=yes local-address=192.168.8.250 dns-server=192.168.8.250 remote-address=vpn-pool
secret add name=user profile=vpn-profile password=password

Включить интерфейс SSTP VPN-сервера:

/interface sstp-server server
set enabled=yes default-profile=vpn-profile authentication=mschap2 certificate=server-certificate force-aes=yes pfs=yes

Не забудьте настроить брандмауэр при необходимости (TCP-порт 443):

/ip firewall filter
add chain=input protocol=tcp dst-port=443 action=accept place-before=0 comment="Allow SSTP"

Теперь перейдите в «Файлы» и экспортируйте сертификат, просто перетащив его на рабочий стол.



RUTXxx (клиентская) конфигурация

Войдите в RUTxxx WebUI и выберите Сервис> VPN> SSTP. Там создайте новую конфигурацию, написав имя конфигурации и нажав кнопку Добавить. Это должно появиться через несколько секунд. Затем нажмите Редактировать.

Теперь примените следующую конфигурацию.

1. Включить экземпляр.
2. Запишите IP-адрес сервера (общедоступный IP-адрес MikroTik).
3. Напишите имя пользователя (напишите имя пользователя, которое вы создали с помощью этой команды: secret add name = user profile = vpn-profile password = password).
4. Напишите пароль (напишите пароль, который вы создали с помощью этой команды: secret add name = user profile = vpn-profile password = password).
5. Загрузите сертификат CA (файл, который вы экспортировали из MikroTik).
6. Нажмите Сохранить и применить.


Тестирование конфигурации

Попробуйте пропинговать удаленную конечную точку VPN через CLI или SSH, используя эту команду:

ping 192.168.8.250

Оборудование

  • Промышленный роутер Teltonika RUTX12 LTE Cat.6

    Код: 47654  Под заказ Срок поставки: уточняйте
    Промышленный роутер Teltonika RUTX12 LTE Cat.6 - фото
    69 253 ₽
    Без НДС
    Оптовая цена по запросу
    Всепогодный маршрутизатор LTE Cat.6, 4х Gigabit RJ45, USB 2.0, WiFi 2.4 / 5 GHz, с поддержкой MU-MIMO, модулем Bluetooth, в комплекте с внешними антеннами.
  • Маршрутизатор Teltonika RUTX10

    Код: 47341  Под заказ Срок поставки: уточняйте
    Маршрутизатор Teltonika RUTX10 - фото
    14 320 ₽
    Без НДС
    Оптовая цена по запросу
    Маршрутизатор, оснащенный Wave-2 802.11ac двух диапазонным Wi-Fi со скоростью до 867 Мбит/с, 4х Gigabit Ethernet со скоростью до 1000 Мбит/с, модулем Bluetooth LE
  • 4G-роутер Teltonika RUTX11

    Код: 47342  Под заказ Срок поставки: уточняйте
    4G-роутер Teltonika RUTX11 - фото
    50 809 ₽
    Без НДС
    Оптовая цена по запросу
    4G-роутер, четырехъядерный процессор ARM Cortex A7 717 МГц и 256 МБ, двухдиапазонный 802.11ac Wave 2

Поиск по каталогу
Например Termit iRZ модем Rl21 Atm21 Антенна 906 sma 47270
По Вашему запросу «» ничего не найдено
Отправьте сообщение, мы постараемся помочь
Поиск по базе знаний
Например ATM control iRZ collector iRZ bridge Termit Настройка ALFA
Мы используем cookie-файлы